Make YAP respect 'Run with graphics processor'

Bug reporting and troubleshooting problems
Message
Author
Enig123
Posts: 6
Joined: Tue Aug 07, 2018 5:53 pm

Make YAP respect 'Run with graphics processor'

#1 Post by Enig123 » Sat Aug 11, 2018 2:24 am

My media laptop has an integrated gpu and a discrete high performance nVidia gpu.

Run YAP by right-click and choose 'Run with graphics process' will use the high performance gpu initially, but after importing another file with Ctrl-O, I got sluggish playback of videos.

Is it possible that YAP does not respect 'Run with graphics processor' after some kind of actions? And if it is, I hope that Orf can address the issue in the near future.

User avatar
Orfsoft
Founder
Posts: 24
Joined: Wed Jul 04, 2018 7:36 am
Location: Russia
Contact:

Re: Make YAP respect 'Run with graphics processor'

#2 Post by Orfsoft » Sat Aug 11, 2018 8:48 am

Is it possible that YAP does not respect 'Run with graphics processor' after some kind of actions?
Not possible, I think. Image processing use the default Direct3D11 adapter, it is created on player startup and it is not changed while player is running.

And, by the way, are your talking about EVR CP video renderer?

Enig123
Posts: 6
Joined: Tue Aug 07, 2018 5:53 pm

Re: Make YAP respect 'Run with graphics processor'

#3 Post by Enig123 » Sat Aug 11, 2018 6:11 pm

I was using madVR renderer.

User avatar
Orfsoft
Founder
Posts: 24
Joined: Wed Jul 04, 2018 7:36 am
Location: Russia
Contact:

Re: Make YAP respect 'Run with graphics processor'

#4 Post by Orfsoft » Sun Aug 12, 2018 6:55 am

Am I understand correctly, that you when you start player, you can play video from playlist without any problem, and it become sluggish after you use import? Did that happened only with madVR? How did EVR CP behave in same scenario? What happened, if you restart player after import and play the same video from playlist?

Enig123
Posts: 6
Joined: Tue Aug 07, 2018 5:53 pm

Re: Make YAP respect 'Run with graphics processor'

#5 Post by Enig123 » Sun Aug 12, 2018 10:24 pm

This will happen when I put the cursor at seek bar, YAP will show screenshot of that timestamp, then the playback became sluggish. I assume the preview triggered the YAP not run on chosen discrete gpu anymore.

User avatar
Orfsoft
Founder
Posts: 24
Joined: Wed Jul 04, 2018 7:36 am
Location: Russia
Contact:

Re: Make YAP respect 'Run with graphics processor'

#6 Post by Orfsoft » Mon Aug 13, 2018 8:27 am

So, you're using video preview and running video at a same time. Look likes you hardware ain't powerful enough to handle this. Try to pause video, before using video preview.
If you're on a latest Win10, you can use Task manager/performance tab to monitor your hardware usage. You can see there what video card is currently utilized too.
First you've said it was related to import, now you're saying it related to video preview. Those are a bit confusing reports. You've also ignored all questions from my previous message, but answering those might help me to help you.

Enig123
Posts: 6
Joined: Tue Aug 07, 2018 5:53 pm

Re: Make YAP respect 'Run with graphics processor'

#7 Post by Enig123 » Mon Aug 13, 2018 5:01 pm

Sorry for the confusion due to my poor descriptions.

The sluggish after preview happened on my other machine, which runs windows 8.1, with a discrete nVidia card.

It's not playback sluggish while preview, after preview instead. To be precise, once I put the cursor near the progress bar, and then move the cursor somewhere else and the bar disappeared, the playback of the video will started sluggish and will not come back to normal without a restart of the player.

User avatar
Orfsoft
Founder
Posts: 24
Joined: Wed Jul 04, 2018 7:36 am
Location: Russia
Contact:

Re: Make YAP respect 'Run with graphics processor'

#8 Post by Orfsoft » Mon Aug 13, 2018 7:42 pm

I don't know what else to guess. Video preview is not related with madVR in any way, and I don't know the way one can affect the other. Did you try to look into Task manager/performance tab to monitor the usage of your GPUs when sluggish happens ?

User avatar
Orfsoft
Founder
Posts: 24
Joined: Wed Jul 04, 2018 7:36 am
Location: Russia
Contact:

Re: Make YAP respect 'Run with graphics processor'

#9 Post by Orfsoft » Thu Aug 16, 2018 10:26 am

Until more feedback comes on this matter, I consider nothing need to be done to make YAP respect 'Run with graphics processor', because it already did...

Enig123
Posts: 6
Joined: Tue Aug 07, 2018 5:53 pm

Re: Make YAP respect 'Run with graphics processor'

#10 Post by Enig123 » Sat Sep 08, 2018 5:41 am

Orfsoft wrote:
Mon Aug 13, 2018 7:42 pm
I don't know what else to guess. Video preview is not related with madVR in any way, and I don't know the way one can affect the other. Did you try to look into Task manager/performance tab to monitor the usage of your GPUs when sluggish happens ?
Can't do it since the laptop with the problem is under windows 8.1, where Task Manager does not show GPU infos.

I may have a bad theory about the origin of the problem, however, the issue itself is real. It's still there with 0.9.2.

The symptom of sluggish, did happen not right after preview, it stayed normal for a while before it gets sluggish. Now I have to be very careful NOT move my cursor to the progressive bar.

My discrete graphics card nVidia 880M is powerful enough to handle madVR with proper settings, while the Intel 4600 is far from that. This is why I firstly rush into the conclusion, which is not been thoroughly confirmed.

Edit: Alright, it might turn out to be a power state issue with me, since after the sluggish happened, when I configure madVR's NGU to 'high', the issue is gone, only back to sluggish again after I set it back to 'low'.

Post Reply